Commit eee13b77 authored by Mark Andrews's avatar Mark Andrews
Browse files

make 'configure --with-gssapi=yes' fatal if support is not found

(cherry picked from commit e420078c)
parent 64196225
Pipeline #13724 passed with stages
in 17 minutes and 5 seconds
......@@ -841,7 +841,6 @@ infodir
docdir
oldincludedir
includedir
runstatedir
localstatedir
sharedstatedir
sysconfdir
......@@ -999,7 +998,6 @@ datadir='${datarootdir}'
sysconfdir='${prefix}/etc'
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'
runstatedir='${localstatedir}/run'
includedir='${prefix}/include'
oldincludedir='/usr/include'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
......@@ -1252,15 +1250,6 @@ do
| -silent | --silent | --silen | --sile | --sil)
silent=yes ;;
-runstatedir | --runstatedir | --runstatedi | --runstated \
| --runstate | --runstat | --runsta | --runst | --runs \
| --run | --ru | --r)
ac_prev=runstatedir ;;
-runstatedir=* | --runstatedir=* | --runstatedi=* | --runstated=* \
| --runstate=* | --runstat=* | --runsta=* | --runst=* | --runs=* \
| --run=* | --ru=* | --r=*)
runstatedir=$ac_optarg ;;
-sbindir | --sbindir | --sbindi | --sbind | --sbin | --sbi | --sb)
ac_prev=sbindir ;;
-sbindir=* | --sbindir=* | --sbindi=* | --sbind=* | --sbin=* \
......@@ -1398,7 +1387,7 @@ fi
for ac_var in exec_prefix prefix bindir sbindir libexecdir datarootdir \
datadir sysconfdir sharedstatedir localstatedir includedir \
oldincludedir docdir infodir htmldir dvidir pdfdir psdir \
libdir localedir mandir runstatedir
libdir localedir mandir
do
eval ac_val=\$$ac_var
# Remove trailing slashes.
......@@ -1551,7 +1540,6 @@ Fine tuning of the installation directories:
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
--runstatedir=DIR modifiable per-process data [LOCALSTATEDIR/run]
--libdir=DIR object code libraries [EPREFIX/lib]
--includedir=DIR C header files [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc [/usr/include]
......@@ -1648,7 +1636,7 @@ Optional Packages:
PKCS11 provider)
--with-gssapi=PATH|/path/krb5-config
Specify path for system-supplied GSSAPI
[default=yes]
[default=auto]
--with-lmdb=PATH build with LMDB library [yes|no|path]
--with-libxml2=PATH build with libxml2 library [yes|no|path]
--with-libjson=PATH build with libjson0 library [yes|no|path]
......@@ -16043,7 +16031,7 @@ $as_echo_n "checking for GSSAPI library... " >&6; }
if test "${with_gssapi+set}" = set; then :
withval=$with_gssapi; use_gssapi="$withval"
else
use_gssapi="yes"
use_gssapi="auto"
fi
......@@ -16183,7 +16171,7 @@ esac
case "$host" in
*darwin*)
if test "yes" = "$use_gssapi"
if test "yes" = "$use_gssapi" -o "auto" = "$use_gssapi"
then
use_gssapi=framework
fi
......@@ -16196,7 +16184,7 @@ esac
# for the specification of gssapi and krb5 headers in different locations,
# which probably ought to be fixed although fixing might raise the issue of
# trying to build with incompatible versions of gssapi and krb5.
if test "yes" = "$use_gssapi"
if test "yes" = "$use_gssapi" -o "auto" = "$use_gssapi"
then
# first, deal with the obvious
if test \( -f /usr/include/kerberosv5/krb5.h -o \
......@@ -16220,8 +16208,11 @@ then
break
fi
fi
use_gssapi="no"
done
if test "auto" = "$use_gssapi"
then
use_gssapi="no"
fi
fi
fi
......
......@@ -922,8 +922,8 @@ AC_MSG_CHECKING(for GSSAPI library)
AC_ARG_WITH(gssapi,
AS_HELP_STRING([--with-gssapi=[PATH|[/path/]krb5-config]],
[Specify path for system-supplied GSSAPI
[default=yes]]),
use_gssapi="$withval", use_gssapi="yes")
[default=auto]]),
use_gssapi="$withval", use_gssapi="auto")
# first try using krb5-config, if that does not work then fall back to "yes" method.
......@@ -977,7 +977,7 @@ esac
case "$host" in
*darwin*)
if test "yes" = "$use_gssapi"
if test "yes" = "$use_gssapi" -o "auto" = "$use_gssapi"
then
use_gssapi=framework
fi
......@@ -990,7 +990,7 @@ esac
# for the specification of gssapi and krb5 headers in different locations,
# which probably ought to be fixed although fixing might raise the issue of
# trying to build with incompatible versions of gssapi and krb5.
if test "yes" = "$use_gssapi"
if test "yes" = "$use_gssapi" -o "auto" = "$use_gssapi"
then
# first, deal with the obvious
if test \( -f /usr/include/kerberosv5/krb5.h -o \
......@@ -1014,8 +1014,11 @@ then
break
fi
fi
use_gssapi="no"
done
if test "auto" = "$use_gssapi"
then
use_gssapi="no"
fi
fi
fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment