Teach configure to find Python 3.9, 3.10, and 3.11

FreeBSD does not have python3 symlink, and ./configure relies on finding
python3.X binaries instead.
71 jobs for !6662 with mnowak/configure-find-newer-python-versions in 18 minutes and 4 seconds (queued for 5 seconds)
latest merge request