Improve the error message about missing PLY Python package

Previously, only a message about missing Python was printed, which was
misleading to many users.  The new message clearly states that Python
AND PLY is required and prints basic instructions how to install PLY
package.

(cherry picked from commit 55b48700)
41 jobs for !1919 with 958-improve-message-about-python-ply-v9_14 in 20 minutes and 29 seconds (queued for 3 seconds)
merge request