Remove AX_CHECK_OPENSSL macro

OpenSSL supports pkg-config method since the 0.9.8 version and we
already require pkg-config for other mandatory libraries.  Also
the way the AX_CHECK_OPENSSL macro was integrated into the configure
script was confusing - the macro would be used only if the libcrypto.pc
and libssl.pc file are not usable, so calling ./configure
--with-openssl=/usr/local would have no effect when PKG_CHECK_MODULES
would be successful.
73 jobs for !5378 with 2806-remove-ax_check_openssl in 19 minutes and 18 seconds (queued for 8 seconds)
latest merge request