Install gcovr to Debian Buster amd64 image

Also sort "VENDOR-VERSION-ARCH" variables.
parent 4fba1bb3
Pipeline #47803 canceled with stage
in 14 minutes and 27 seconds
...@@ -32,21 +32,22 @@ abi_check_debian_buster_amd64 := yes ...@@ -32,21 +32,22 @@ abi_check_debian_buster_amd64 := yes
coccinelle_debian_buster_amd64 := yes coccinelle_debian_buster_amd64 := yes
compiledb_debian_buster_amd64 := yes compiledb_debian_buster_amd64 := yes
cppcheck_debian_buster_amd64 := yes cppcheck_debian_buster_amd64 := yes
nodejs_debian_buster_amd64 := 12
danger_debian_buster_amd64 := yes danger_debian_buster_amd64 := yes
dnstap_alpine_3.12_amd64 := yes dnstap_alpine_3.12_amd64 := yes
dnstap_debian_buster_amd64 := yes
dnstap_centos_centos7_amd64 := yes dnstap_centos_centos7_amd64 := yes
dnstap_debian_buster_amd64 := yes
dnstap_debian_sid_amd64 := yes dnstap_debian_sid_amd64 := yes
dnstap_debian_sid_i386 := yes dnstap_debian_sid_i386 := yes
gcovr_debian_buster_amd64 := yes
nodejs_debian_buster_amd64 := 12
python_qa_debian_buster_amd64 := yes python_qa_debian_buster_amd64 := yes
respdiff_debian_buster_amd64 := yes respdiff_debian_buster_amd64 := yes
shellcheck_debian_sid_amd64 := yes shellcheck_debian_sid_amd64 := yes
sphinx_debian_buster_amd64 := yes sphinx_debian_buster_amd64 := yes
# Install latest stable version of LLVM/Clang # Install latest stable version of LLVM/Clang
clang_debian_stretch_amd64 := 10
clang_debian_buster_amd64 := 10 clang_debian_buster_amd64 := 10
clang_debian_stretch_amd64 := 10
TARGETS := $(foreach arch,$(ARCHS),$(foreach distro,$(DISTROS),$(foreach version,$($(distro)_VERSIONS),$(distro)-$(version)-$(arch)))) TARGETS := $(foreach arch,$(ARCHS),$(foreach distro,$(DISTROS),$(foreach version,$($(distro)_VERSIONS),$(distro)-$(version)-$(arch))))
...@@ -88,6 +89,7 @@ $(TARGETS): COMPILEDB = $(compiledb_$(VENDOR)_$(VERSION)_$(ARCH)) ...@@ -88,6 +89,7 @@ $(TARGETS): COMPILEDB = $(compiledb_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): CPPCHECK = $(cppcheck_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): CPPCHECK = $(cppcheck_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): DANGER = $(danger_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): DANGER = $(danger_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): DNSTAP = $(dnstap_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): DNSTAP = $(dnstap_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): GCOVR = $(gcovr_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): NODEJS = $(nodejs_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): NODEJS = $(nodejs_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): PYTHON_QA = $(python_qa_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): PYTHON_QA = $(python_qa_$(VENDOR)_$(VERSION)_$(ARCH))
$(TARGETS): RESPDIFF = $(respdiff_$(VENDOR)_$(VERSION)_$(ARCH)) $(TARGETS): RESPDIFF = $(respdiff_$(VENDOR)_$(VERSION)_$(ARCH))
...@@ -107,6 +109,7 @@ $(TARGETS): ...@@ -107,6 +109,7 @@ $(TARGETS):
-e 's,@CPPCHECK@,$(CPPCHECK),g' \ -e 's,@CPPCHECK@,$(CPPCHECK),g' \
-e 's,@DANGER@,$(DANGER),g' \ -e 's,@DANGER@,$(DANGER),g' \
-e 's,@DNSTAP@,$(DNSTAP),g' \ -e 's,@DNSTAP@,$(DNSTAP),g' \
-e 's,@GCOVR@,$(GCOVR),g' \
-e 's,@KYUA_GIT_COMMIT@,$(KYUA_GIT_COMMIT),g' \ -e 's,@KYUA_GIT_COMMIT@,$(KYUA_GIT_COMMIT),g' \
-e 's,@NODEJS@,$(NODEJS),g' \ -e 's,@NODEJS@,$(NODEJS),g' \
-e 's,@PYTHON_QA@,$(PYTHON_QA),g' \ -e 's,@PYTHON_QA@,$(PYTHON_QA),g' \
......
...@@ -109,6 +109,7 @@ RUN if [ -n "@NODEJS@" ] && [ "@DANGER@" = "yes" ]; then npm install -g danger@9 ...@@ -109,6 +109,7 @@ RUN if [ -n "@NODEJS@" ] && [ "@DANGER@" = "yes" ]; then npm install -g danger@9
# https://github.com/danger/python/pull/8, https://github.com/danger/python/pull/9 # https://github.com/danger/python/pull/8, https://github.com/danger/python/pull/9
RUN if [ -n "@NODEJS@" ] && [ "@DANGER@" = "yes" ]; then pip3 install danger-python && sed -i '/CAN_BE_MERGED/{p;s|CAN|CANNOT|;s|can|cannot|}; s|OPEN = "open"|OPEN = "opened"|' /usr/local/lib/python3.7/dist-packages/danger_python/models.py; fi RUN if [ -n "@NODEJS@" ] && [ "@DANGER@" = "yes" ]; then pip3 install danger-python && sed -i '/CAN_BE_MERGED/{p;s|CAN|CANNOT|;s|can|cannot|}; s|OPEN = "open"|OPEN = "opened"|' /usr/local/lib/python3.7/dist-packages/danger_python/models.py; fi
RUN if [ "@DNSTAP@" = "yes" ]; then apt-get -y install libfstrm-dev libprotobuf-c-dev protobuf-c-compiler; fi RUN if [ "@DNSTAP@" = "yes" ]; then apt-get -y install libfstrm-dev libprotobuf-c-dev protobuf-c-compiler; fi
RUN if [ "@GCOVR@" = "yes" ]; then apt-get -y install gcovr; fi
RUN if [ "@PYTHON_QA@" = "yes" ]; then pip3 install flake8==3.8.3 pylint==2.5.3; fi RUN if [ "@PYTHON_QA@" = "yes" ]; then pip3 install flake8==3.8.3 pylint==2.5.3; fi
RUN if [ "@RESPDIFF@" = "yes" ]; then apt-get -y install python3-dpkt python3-lmdb python3-numpy python3-scipy python3-tabulate; fi RUN if [ "@RESPDIFF@" = "yes" ]; then apt-get -y install python3-dpkt python3-lmdb python3-numpy python3-scipy python3-tabulate; fi
RUN if [ "@SHELLCHECK@" = "yes" ]; then apt-get -y install shellcheck; fi RUN if [ "@SHELLCHECK@" = "yes" ]; then apt-get -y install shellcheck; fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment