Do not install Sphinx explicitly

Merged Michał Kępień requested to merge michal/do-not-install-sphinx-explicitly into main

Including the Sphinx package in the "pip3 install" invocation causes the docutils version requirements specified by sphinx-rtd-theme (< 0.17) to be overridden by those specified by Sphinx (< 0.18, >= 0.14), resulting in version 0.17.1 of docutils being installed, which is incompatible with the latest version of sphinx-rtd-theme (0.5.2).

As sphinx-rtd-theme depends on the Sphinx package anyway, only include the former in the "pip3 install" invocation to ensure a compatible version of docutils is installed in the relevant Docker image.

Merge request reports