Commit d055308d authored by Michael Graff's avatar Michael Graff
Browse files

search for python, python3, and then python3.1. Require version 3.1. Use...

search for python, python3, and then python3.1.  Require version 3.1.  Use @PYTHON@ in all .in files, and add run_bigtool.in.  This should cover all script wrappers.

git-svn-id: svn://bind10.isc.org/svn/bind10/branches/parkinglot@336 e5f2f494-b856-4b98-b285-d166d9295462
parent 342fdf3d
......@@ -12,6 +12,9 @@ AC_PROG_CXX
AC_PROG_CC
AC_PROG_RANLIB
m4_define([_AM_PYTHON_INTERPRETER_LIST], [python python3 python3.1])
AM_PATH_PYTHON([3.1])
# Checks for libraries.
# Checks for header files.
......@@ -63,10 +66,12 @@ AC_CONFIG_FILES([Makefile
src/lib/dns/Makefile
])
AC_OUTPUT([src/bin/bind-cfgd/bind-cfgd
src/bin/bigtool/run_bigtool
src/bin/bind10/bind10
src/bin/pymsgq/msgq
], [
chmod +x src/bin/bind-cfgd/bind-cfgd
chmod +x src/bin/bigtool/run_bigtool
chmod +x src/bin/bind10/bind10
chmod +x src/bin/pymsgq/msgq
])
......
#! /bin/sh
PYTHON_EXEC=${PYTHON_EXEC:-python3}
PYTHON_EXEC=${PYTHON_EXEC:-@PYTHON@}
BIGTOOL_PATH=.
PYTHONPATH=../../lib/cc/python:../../lib/bigtool/
......
......@@ -3,7 +3,7 @@
BINPATH=@abs_top_srcdir@/src/lib/bind-cfgd/python
LIBPATH=@abs_top_srcdir@/src/lib/cc/python
PYTHON_EXEC=${PYTHON_EXEC:-/usr/bin/python3.0}
PYTHON_EXEC=${PYTHON_EXEC:-@PYTHON@}
PYTHONPATH=${LIBPATH}:${PYTHONPATH} ${PYTHON_EXEC} ${BINPATH}/bind-cfgd.py
#! /bin/sh
PYTHON_EXEC=${PYTHON_EXEC:-/usr/bin/python3.0}
PYTHON_EXEC=${PYTHON_EXEC:-@PYTHON@}
export PYTHON_EXEC
BIND10_PATH=@abs_top_srcdir@/src/bin/bind10
......
#! /bin/sh
PYTHON_EXEC=${PYTHON_EXEC:-python3.1}
PYTHON_EXEC=${PYTHON_EXEC:-@PYTHON@}
export PYTHON_EXEC
MYPATH_PATH=@abs_top_srcdir@/src/bin/pymsgq
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment