Commit 6a95d51e authored by Michal Nowikowski's avatar Michal Nowikowski

various improvements

- improved several fragments of the first 3 chapters in ARM
- added target to top level Makefile for generating PDF docs
- improved formating of ChangeLog
parent 4d3a6d57
......@@ -485,7 +485,7 @@ Kea 1.5.0 released on Dec 14, 2018
start using it.
(Gitlab #186,!163, git 8f7d556456891e7c675082f7e6cc88da71a92fee)
1500 [func, doc] tmark
1500. [func, doc] tmark
Streamlined the isc::dhcp::PacketQueue interface and
added a section on Congestion Handling to the developer's guide.
(Gitlab #278,!162, git 0ce615f5da993ac90f675c5315ba7cb5c2ef3e1c)
......
......@@ -146,6 +146,17 @@ cppcheck:
--template '{file}:{line}: check_fail: {message} ({severity},{id})' \
src
# this is a shortcut that builds only documentation dependecies and documentation itself
gen-docs:
$(MAKE) -C src/lib/asiolink
$(MAKE) -C src/lib/exceptions
$(MAKE) -C src/lib/util
$(MAKE) -C src/lib/cc
$(MAKE) -C tools
$(MAKE) -C doc
$(MAKE) -C doc/guide pdf
# These steps are necessary during installation
install-exec-hook:
mkdir -p $(DESTDIR)${localstatedir}/log/
......
......@@ -123,15 +123,15 @@
</para>
</listitem>
<listitem>
<para>
Botan (at least version 1.9) or OpenSSL (at least version 1.0.1).
Note that Botan version 2 or later and OpenSSL version 1.0.2 or
1.1.0 or later are strongly recommended.
</para>
</listitem>
<listitem>
<para>
OpenSSL (at least version 1.0.1) or Botan (at least version 1.9).
Note that OpenSSL version 1.0.2 or 1.1.0 or later and Botan version 2
or later are strongly recommended.
</para>
</listitem>
<listitem>
<listitem>
<para>
log4cplus (at least version 1.0.3)
development include headers.
......@@ -147,9 +147,8 @@ Debian and Ubuntu:
<listitem>
<para>
A C++ compiler (with C++11 support) and standard development
headers. Kea builds have been tested with GCC g++ 4.7.2 4.7.3
4.8.2 4.8.4 4.8.5 4.9.3 4.9.4 5.3.1 5.4.0 6.3.0 6.3.1
clang-800.0.38 clang-802.0.42 clang-900.0.37
headers. Kea building was checked with GCC g++ 4.8.5 and some later
versions and Clang 800.0.38 and some later versions.
</para>
</listitem>
......@@ -328,23 +327,6 @@ Debian and Ubuntu:
</listitem>
</varlistentry>
<varlistentry>
<term>--with-boost-include</term>
<listitem>
<simpara>Define the path to find the Boost headers.
</simpara>
</listitem>
</varlistentry>
<varlistentry>
<term>--with-botan-config</term>
<listitem>
<simpara>Specify the path to the botan-config
script to build with Botan for cryptographic functions.
</simpara>
</listitem>
</varlistentry>
<varlistentry>
<term>--with-mysql</term>
<listitem>
......@@ -379,7 +361,24 @@ Debian and Ubuntu:
<term>--with-log4cplus</term>
<listitem>
<simpara>Define the path to find the Log4cplus headers
and libraries.
and libraries. Normally this is not necessary.
</simpara>
</listitem>
</varlistentry>
<varlistentry>
<term>--with-boost-include</term>
<listitem>
<simpara>Define the path to find the Boost headers. Normally this is not necessary.
</simpara>
</listitem>
</varlistentry>
<varlistentry>
<term>--with-botan-config</term>
<listitem>
<simpara>Specify the path to the botan-config
script to build with Botan for cryptographic functions. It is prefered to use OpenSSL (see below).
</simpara>
</listitem>
</varlistentry>
......@@ -390,6 +389,7 @@ Debian and Ubuntu:
<simpara>Replace Botan by the OpenSSL the cryptographic library.
By default <command>configure</command> searches for a valid
Botan installation. If one is not found, it searches for OpenSSL.
Normally this is not necessary.
</simpara>
</listitem>
</varlistentry>
......
......@@ -33,7 +33,7 @@
<listitem>CentOS Linux — 7.1804 (aka 7.5)</listitem>
<listitem>Fedora — 28, 29</listitem>
<listitem>Ubuntu — 16.04, 18.04</listitem>
<listitem>Debian GNU/Linux — 7, 8, 9</listitem>
<listitem>Debian GNU/Linux — 8, 9</listitem>
<listitem>FreeBSD — 11.0</listitem>
<listitem>macOS — 10.13, 10.14</listitem>
</itemizedlist>
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment