Commit bcc828c9 authored by Ondřej Surý's avatar Ondřej Surý
Browse files

Remove Debian Jessie from our supported images

parent c0ec1c35
......@@ -171,18 +171,6 @@ fedora_31_amd64:
- amd64
<<: *docker_image_job
debian_jessie_amd64:
stage: images
variables:
DISTROS: debian
VERSIONS: jessie
ARCHS: amd64
tags:
- linux
- docker
- amd64
<<: *docker_image_job
debian_stretch_amd64:
stage: images
variables:
......@@ -258,18 +246,6 @@ ubuntu_bionic_amd64:
- amd64
<<: *docker_image_job
debian_jessie_i386:
stage: images
variables:
DISTROS: debian
VERSIONS: jessie
ARCHS: i386
tags:
- linux
- docker
- i386
<<: *docker_image_job
debian_stretch_i386:
stage: images
variables:
......
......@@ -3,7 +3,7 @@ ARCHS ?= amd64 i386
default_alpine_VERSIONS := 3.10 3.11
default_centos_VERSIONS := centos6 centos7 centos8
default_debian_VERSIONS := jessie stretch buster bullseye sid
default_debian_VERSIONS := stretch buster bullseye sid
default_fedora_VERSIONS := 30 31
default_tumbleweed_VERSIONS := latest
default_ubuntu_VERSIONS := xenial bionic
......
FROM @SOURCE_IMAGE@
MAINTAINER BIND 9 Developers <bind9-dev@isc.org>
ENV DEBIAN_FRONTEND noninteractive
ENV LIBUV_VERSION 1.33.1
ENV ATF_VERSION 0.21
ENV LUTOK_VERSION 0.4
ENV KYUA_GIT_COMMIT @KYUA_GIT_COMMIT@
......@@ -57,10 +56,12 @@ RUN apt-get -y install \
liblmdb-dev \
liblua5.1-0-dev \
liblua5.2-dev \
libmaxminddb-dev \
libnet-dns-perl \
libtool \
libsqlite3-dev \
libssl-dev \
libuv1-dev \
libxml-simple-perl \
libxml2-dev \
libxml2-utils \
......@@ -81,7 +82,6 @@ RUN apt-get -y install \
zip \
zlib1g-dev
RUN if [ -n "@COCCINELLE@" ]; then apt -y install coccinelle; fi
RUN if [ "@VERSION@" != "jessie" ]; then apt-get -y install libmaxminddb-dev libuv1-dev; fi
RUN if [ -n "@CLANG@" ]; then \
apt-get -y install \
llvm-9 \
......@@ -124,8 +124,6 @@ RUN if [ -n "@DNSTAP@" ]; then apt-get -y install libfstrm-dev libprotobuf-c-dev
RUN if [ "@SOFTHSM@" -ge "2" ]; then apt-get -y install libsofthsm2 softhsm2; fi
RUN if [ "@SOFTHSM@" -lt "2" ]; then apt-get -y install libsofthsm softhsm; fi
RUN if [ "@VERSION@" = "sid" ]; then apt-get -y install shellcheck; fi
RUN if [ "@VERSION@" = "jessie" ]; then curl -sSL https://github.com/libuv/libuv/archive/v$LIBUV_VERSION.tar.gz | tar -xz -C /usr/src; fi
RUN if [ "@VERSION@" = "jessie" ]; then cd /usr/src/libuv-$LIBUV_VERSION && ./autogen.sh && ./configure --prefix /usr && make && make install; fi
RUN curl -sSL https://github.com/jmmv/atf/releases/download/atf-$ATF_VERSION/atf-$ATF_VERSION.tar.gz | tar -xz -C /usr/src
RUN cd /usr/src/atf-$ATF_VERSION && autoreconf -fi && ./configure --prefix /usr && make && make install
RUN ldconfig
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment