Commit 0e1f718a authored by Tomek Mrugalski's avatar Tomek Mrugalski 🛰
Browse files

[master] Merge branch 'trac3511' (pkg-config dependency removal)

Conflicts:
	ChangeLog
parents 4e9e28dc 99a5a2db
828. [build] jreed
The configure script no longer requires pkg-config.
(Trac #3511, git 99a5a2db8c011b358873d485ac48f7c78ac6374c)
827. [build] jiri, tomek
Deprecated AC_PROG_LIBTOOL macro replaced by LT_INIT.
(Trac #3525, git 6c0aacf29fae1d0501ca69ff6324df8d4fc8c7ee)
......
......@@ -1199,12 +1199,6 @@ AC_SUBST(GTEST_LDFLAGS)
AC_SUBST(GTEST_LDADD)
AC_SUBST(GTEST_SOURCE)
dnl check for pkg-config itself
AC_CHECK_PROG(HAVE_PKG_CONFIG, pkg-config, yes, no)
if test "x$HAVE_PKG_CONFIG" = "xno" ; then
AC_MSG_ERROR(Please install pkg-config)
fi
#
# ASIO: we extensively use it as the C++ event management module.
#
......
......@@ -142,8 +142,7 @@ Debian and Ubuntu:
<listitem>
<para>
The development tools "make" and "pkg-config".
<!-- @todo update this list, pkg-config shouldn't be required -->
The development tools "make".
</para>
</listitem>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment